To register and login, use your Google, Twitter, Facebook, LinkedIn, or OpenID credentials.

This is allowing us to stop most spam registrations. We've deleted most of the spam accounts that got through, and we're closely watching for more.

eclipse, could not find PdCore.apk

sporsmaal.teglegsporsmaal.tegleg Posts: 16
edited November -1 in Pd Everywhere
hello
after much messing around, yesterday i finally managed to set up eclipse and could run the examples on my phone yay!
however, today i get that error in the title.

ive tried clean and build, delete gen and build again.
tried removing and adding pdcore as android library.

any odeas?
thanks

Comments

  • so i started again fom scratch, downloaded libpd for android again.
    imported projects into workspace.
    a few cleans/builds delete 'gen' and build again to get rid of the errors
    tried to run PDTest
    still the same, heres the log

    [2012-07-04 17:29:43 - PdTest] Android Launch!
    [2012-07-04 17:29:43 - PdTest] adb is running normally.
    [2012-07-04 17:29:43 - PdTest] Performing org.puredata.android.test.PdTest activity launch
    [2012-07-04 17:29:43 - PdTest] Automatic Target Mode: using device 'MT-_0ijGAsXo9rAzZBjhAkIlERA'
    [2012-07-04 17:29:43 - PdTest] Uploading PdTest.apk onto device 'MT-_0ijGAsXo9rAzZBjhAkIlERA'
    [2012-07-04 17:29:44 - PdTest] Installing PdTest.apk...
    [2012-07-04 17:29:49 - PdTest] Success!
    [2012-07-04 17:29:49 - PdCore] Could not find PdCore.apk!
    [2012-07-04 17:29:49 - PdTest] Starting activity org.puredata.android.test.PdTest on device MT-_0ijGAsXo9rAzZBjhAkIlERA
    [2012-07-04 17:29:51 - PdTest] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=org.puredata.android.test/.PdTest }
  • pbrinkmannpbrinkmann Posts: 685 ✭✭
    This is the same question that we discussed over at GitHub, right? Just to sum up, the solution is to use git from the command line (git bash on Windows). I also updated the README.txt of pd-for-android.
  • yes its the same question, i have managed to use git bash to download libpd thanks.
    the example projects work fine after clean and rebuild.

    now im facing the problem of starting a new project.
    im following the instructions to the letter, every time i try to add PdCore and build and run the project it crashes:
    java.lang.NoClassDefFoundError: org.puredata.android.io.AudioParameters
    i have pdcore as a project in my workspace and have the pd imports set up in my activity class.

    so i go to the project properties > android >libraries
    and the pdcore has a red cross.
    so i remove> apply and add it again >apply.

    no matter how many times i clean and build it always gives this error.
  • pbrinkmannpbrinkmann Posts: 685 ✭✭
    Not sure what's going on here. Try creating a new Android project and add PdCore as an Android library before you do anything else. In particular, don't import classes from PdCore before you add PdCore as a library dependency. Good luck...
  • Hi

    I'm not sure if people are still experiencing this issue but I ran into it today and was able to fix it - although I had a reference to PdCore library it was lost in the Project->Properties->Android->Library. I.e. I was able to compile my code and using PdCore libraries but PdCore wasn't being deployed. I'm not quite sure how this works (i.e. being able to have references to PdCore but not having it in my references) but it happened. After adding the PdCore library again I was able to deploy.

    Thanks Josh

Sign In or Register to comment.