To register and login, use your Google, Twitter, Facebook, LinkedIn, or OpenID credentials.

This is allowing us to stop most spam registrations. We've deleted most of the spam accounts that got through, and we're closely watching for more.

Software issues

miguelmiguel Posts: 3
edited September 2012 in Xth Sense: biophysical music

Hi Marco,

Got the sensor fixed and am getting signal ok into my laptop. However the patch is not running properly. When I open Xth-Sense.pd I get the following on the PD window:

error: [import]: can't load library in 'iemguts'
... you might be able to track this down from the Find menu.
error: [import]: can't load library in 'soundhack'
[symbol2list] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
[split_path] $Revision: 1.1 $
written by Hans-Christoph Steiner hans@at.or.at
[time] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
[date] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
[demultiplex] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
expr, expr~, fexpr~ version 0.4 under GNU General Public License
[tabdump] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
[limiter~] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
[z~] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
canvasposition
... couldn't create
canvasposition
... couldn't create
canvasposition
... couldn't create
this is pddplink 0.1, 3rd alpha build...
[pack~] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
[repack] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
[sum] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
canvasposition
... couldn't create
routeOSC object version 1.0 by Martin Peach, based on OSCroute by Matt Wright. pd: jdl Win32 raf.
OSCroute Copyright © 1999 Regents of the Univ. of California. All Rights Reserved.
canvasposition
... couldn't create
canvasindex
... couldn't create
sendcanvas 1
... couldn't create
canvasposition 1
... couldn't create
canvasdelete
... couldn't create
canvasindex
... couldn't create
sendcanvas 1
... couldn't create
canvasposition 1
... couldn't create
canvasdelete
... couldn't create
canvasindex
... couldn't create
sendcanvas 1
... couldn't create
canvasposition 1
... couldn't create
canvasdelete
... couldn't create
canvasindex
... couldn't create
sendcanvas 1
... couldn't create
canvasposition 1
... couldn't create
canvasdelete
... couldn't create
canvasindex
... couldn't create
sendcanvas 1
... couldn't create
canvasposition 1
... couldn't create
canvasdelete
... couldn't create
canvasindex
... couldn't create
sendcanvas 1
... couldn't create
canvasposition 1
... couldn't create
canvasdelete
... couldn't create
[demultiplex~] part of zexy-2.2.3 (compiled: Jun 5 2009)
Copyright (l) 1999-2008 IOhannes m zmölnig, forum::für::umläute & IEM
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'bang'
error: inlet: expected '' but got 'bang'
error: inlet: expected '' but got 'bang'
error: inlet: expected '' but got 'bang'
error: inlet: expected '' but got 'bang'
error: inlet: expected '' but got 'bang'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'
error: inlet: expected '' but got 'list'

It seems clear that it is not finding the support libraries which I've put in /home/username/Library/PD/ as suggested in the Xth-Sense documentation.

Should I be using any specific version of PD?
At the moment I am running Pd version 0.41.4-extended

Answers

  • marco_donnarummamarco_donnarumma Posts: 71 admin
    edited September 2012

    Hey Miguel,
    yes, the software is not tested on 41.4, it is from 42.5 and newer.

    Your problem is with the iemguts library, which can't be loaded.
    I guess you're on Mac; on Mac OSX 10.6 or newer, the binaries usually work out of the box.

    Which OS do you have?

  • Hey Marco,
    Think it is sorted. I've updated PD and moved the iemguts binaries. I had the whole Xth-Sense_additional-libs_MacOSX/ folder inside my home/user/Library/PD/ folder. Apparently it only looks one folder level. I just moved iemguts/ and soundhack/ folders up to the /PD/ level.

    I no longer get error messages. Unfortunately I've left my sensor at the office this afternoon, will test tomorrow.

    cheers

  • oh that's good to know!
    Yes, didn't think about that.

    The .zip file Xth-Sense_additional-libs_MacOSX, as I zipped it on my machine, contains only the 2 folders iemguts and soundhack ready to be moved, BUT, on Mac the enclosing folder is created arbitrarily with the name of the zip file.

    I'll try to make this clearer in the tutorial.

    thanks for reporting, and have fun now!
    :)
    cheers,

  • All working now!

    2cm diameter silicon made all the difference for the amplification. I soldered the microphone to a small bit of perfboard to make it more stable. I still think the silicon case can be made easier and will experiment with something along the lines of these ( http://www.rre.co.uk/RubberWashers20mm.html ) next week.

    Happy days!

     - Miguel
    
  • JorgeJorge Posts: 1

    Hello !!!

    I Hope everything goes well with your sensors ! :)

    For me..., I think I have a problem, Please, I hope you can help me..., I made all (in a good way I think) , when Im testing the sensor in the Pd patch, Yes I see something in the red graph, but looks it don´t respond to my contractions..., I only can hear a constant sound (with the frequency in 80) like a deep, low sound and this is when I turn all the vol. up in my sound interface...,and then nothing changes...,

    The numbers 1 and 2 in the AUDIO INPUTS of "Test Audio Midi" changes a lot and quickly..., the same with the bars beside the red scope.

    Has someone the same problem ?...,

    Know What happens ?

    Thank You Very Much for your time !!!...

    • J
  • marco_donnarummamarco_donnarumma Posts: 71 admin
    edited October 2012

    hey, check that Pd is actually using your sound interface (I assume you're talking about an external one). It seems like Pd could be listening to the mic of your laptop rather than the interface.
    Go to Media > portaudio and from the dropdown menu select your external soundcard.
    hope that helps!

  • 51joe51joe Posts: 5

    hi, i've checked my sound interface, installed the libraries and have updated PD to 0.42.5-extended. I can hear the Test Audio tone.

    I've built the sensor & I'm getting wav forms in the deck & the sliders are moving around. But i'm not hearing anything?

  • Tab Media > sound ON.

    then in the XS software make sure all rectangular buttons labelled AUDIO OFF, actually say AUDIO ON. Just click them :)

    also see: http://res.marcodonnarumma.com/projects/xth-sense/#troubleshooting

  • yiannisyiannis Posts: 1
    Hi !

    Can you please tell me anyone how can I move the files to /home/username/Library/Pd ?
    I mean I cant find this on my mac.
  • marco_donnarummamarco_donnarumma Posts: 71 admin
    http://osxdaily.com/2011/07/04/show-library-directory-in-mac-os-x-lion/
    Say thanks to Apple for hiding an important folder like that to you after spending thousands money for your laptop :)
Sign In or Register to comment.