To register and login, use your Google, Twitter, Facebook, LinkedIn, or OpenID credentials.

This is allowing us to stop most spam registrations. We've deleted most of the spam accounts that got through, and we're closely watching for more.

[READ ME FIRST] Xth Sense Troubleshooting

marco_donnarummamarco_donnarumma Posts: 72 admin

Here are some common issues that are easily solved by following the guidelines below.

Before starting with the Xth Sense, it can save you a lot of headaches to make sure that:

a) the XS sensor is properly connected to your sound card or computer;
b) the battery in the XS sensor box is fully charged;
c) the buttons labeled “Audio.OFF” that you find in the Analysis module and in each Workspace are ON.


\\\\\\\\\\\\\\\\ 1_ I added the required libraries to /home/username/Library/Pd/ but Pd don't load them at startup.

[From Miguel Ortiz post] Check whether you have the whole Xth-Sense_additional-libs... folder inside your
home/user/Library/PD/ folder. If so, you need to move the iemguts/ and soundhack/ folders up to the /Pd/ level.

\\\\\\\\\\\\\\\\ 2_There is no sound coming out of the XS software and nothing happens.

Make sure that the Pd audio engine is ON (keyboard shortcut is ctl+.). You should hear sound now, if not find the Media tab, then click Test Audio and MIDI. There you can activate a tone generator to test the audio. If you hear the high pitched tone the audio engine in Pd is active. This means something is wrong within your XS patch. Check that the buttons labeled “Audio.OFF” that you find in the Analysis module and in each Workspace are ON. Double check that you connected properly the chords among the objects you created in the Workspace.

\\\\\\\\\\\\\\\\ 3_ I see number boxes and sliders moving in the XS, but I can’t hear any sound.

The Pd audio engine in this case is active. Check that the buttons labeled “Audio.OFF” that you find in the Analysis module and in each Workspace are ON. If so, there’s something wrong with the way you connected the objects in the Workspace. Double check and make proper connections. Still no sound? Have you increased the volume of the channels you are using by sliding up the faders in the Mixer?

\\\\\\\\\\\\\\\\ 4_ I try to set a mapping definition, but the Router keeps reporting the same parameter, but not the one I chose.

This happens because when the Pd audio engine is ON the control values are continuously active. Solution: simply switch the Pd audio OFF while you set your mapping definitions. When you are done, you can switch the Pd audio ON again.


  • MarceloMarcelo Posts: 1

    I'm trying to set Xth Sense for the first time and can't even start a UI like shown at What I have instead is a layout lacking many elements and details (please see screenshot and a pd window full of failures to open or find Xth Sense's components (

    My doubts are I never had a folder called /home/-username-/pd-externals, like the GET STARTED .pdf says. I firstly created it and, as UI looked like description above, I released all files from their folders (so .pd files from Xth-Sense-lib/, iemguts/ and soundhack/ are now mixed). Just then I got a better UI, but still a bunch of failures at pd window.

    I'm using pd 0.46 on a Debian Jessie 64bit installation.

    I'll appreciate your help very much.


Sign In or Register to comment.