To register and login, use your Google, Twitter, Facebook, LinkedIn, or OpenID credentials.

This is allowing us to stop most spam registrations. We've deleted most of the spam accounts that got through, and we're closely watching for more.

Libpd issues on Android 4.1.2 (Motorola Droid 4)

cloud2GNDcloud2GND Posts: 3
edited April 2013 in Pd Everywhere

Hello - I am new libpd user developing on Android. I have a test device, a Motorola Droid 4, which was recently updated to Android 4.1.2. With the update to 4.1.2, libpd audio playback is now constantly broken up with gaps, maybe 50% duty cycle. I have tried PdTest from latest github version and it experiences the issue, so I don't think its a client code problem.

At this point I don't know if its specific to Motorola Droid 4, or Android 4.1.2 in general. Is anyone else testing on a different 4.1.2 device? This is not critical path for me at this point, as we are pre-release and all other devices are working fine, but I wanted to bring it to the communities attention. Eventually I will delve deeper if needed as well, and I'd be happy to try anything out if there are recommendations...

Best regards, Josh cloud2GND

Answers

  • When this happened to us, it was related to screen orientation change causing a second copy of the patch to be loaded. Our app was locked landscape.

  • Hi Daren - Thanks for responding. You are correct that the issue we are experiencing sounds very similar to that case, however I don't believe its this exact issue. We did run into that early in our libpd explorations (as I'm sure many have), but that issue was fixed in our prototype apps, which have no problems on other devices (that issue would be general to all devices I believe).

    More importantly, the issue can be reproduced with only the test applications in the pd-for-android git repo, which I believe handle the screen orientation change correctly (taking our code out of the picture). I have run the same apk for PdTest on many devices and only see the issue on the Droid 4 w/ 4.1.2 (although this is the only 4.1.2 device I've had a chance to test yet).

    I do think its perhaps a clue that this issue produces similar sounding artifacts. Maybe somehow the same thing is happening, but for some new reason on this device or Android 4.1.2. Unfortunately I have still not had the free cycles to follow-up more on this personally, but I keep an eye on this forum in case others have ideas or recommendations for things to try. I'll also follow-up here if I do have a chance to research further. Thanks again.

  • pbrinkmannpbrinkmann Posts: 685 ✭✭

    It appears that this problem is specific to Droid 4. My personal phone was on 4.1.? until very recently and I never experienced such glitches. My first idea would be to hack into the part of the code that configures OpenSL and try different buffer sizes and such. If you find a config that works, please let me know and I'll add it to the config code.

  • Hi Peter - I tried a published libpd app on the device, and it worked correctly, so there must be something weird in my setup or build of PdTest. I will look at the configuration closer as you suggested and try some variations. Once I get it working, I'll follow-up in case it helps anyone else out... Thanks for the input (and the great work with libpd)!

Sign In or Register to comment.